VeraGomezMA5.pdf - ARQUITECTURA DE COMPUTADORES Quinta Pr\u00e1ctica Aritm\u00e9tica Computacional Anngy Nathalia Gomez Avila 2161343 Maria Fernanda Vera Negron

VeraGomezMA5.pdf - ARQUITECTURA DE COMPUTADORES Quinta...

This preview shows page 1 - 3 out of 3 pages.

ARQUITECTURA DE COMPUTADORES Quinta Práctica: Aritmética Computacional Anngy Nathalia Gomez Avila 2161343 Maria Fernanda Vera Negron 2161326 grupo O1 31 de Mayo de 2019 1.1. ¿Qué hace el código? Expliquélo en un diagrama de flujo y un pseudocódigo.
Image of page 1
pseudocodigo definir binary1, binary2 como long i←0; resto←0; suma←20; escribir "Enter the first binary number: "; leer binary1; escribir "Enter the second binary number: "; leer binary2; mientras (binary1 != 0 || binary2 != 0) sum[i++] =(binary1 % 10 + binary2 % 10 + remainder) % 2; remainder =(binary1 % 10 + binary2 % 10 + remainder) / 2; binary1 = binary1 / 10; binary2 = binary2 / 10; finmientras si (remainder != 0) sum[i++] = remainder; finsi --i; escribir "Sum of two binary numbers: "; mientras (i >= 0) escribir sum[i--]; finmientras return 0; 1.2. Teniendo en cuenta que el lenguaje de programación sobre el que esta escrito es evidente, transcribirlo, guardelo con la extensión correspondiente, compilelo y ejecutelo. ¿Qué salida le da? Este programa nos da como salida la suma de dos números binarios en
Image of page 2
Image of page 3

You've reached the end of your free preview.

Want to read all 3 pages?

  • Summer '14
  • Punto, Escritura, Sitio web, Pseudocódigo, Resta

  • Left Quote Icon

    Student Picture

  • Left Quote Icon

    Student Picture

  • Left Quote Icon

    Student Picture

Stuck? We have tutors online 24/7 who can help you get unstuck.
A+ icon
Ask Expert Tutors You can ask You can ask You can ask (will expire )
Answers in as fast as 15 minutes