U4 programação inteira 209 as variáveis de

  • No School
  • AA 1
  • 220

This preview shows page 211 - 215 out of 220 pages.

U4 - Programação inteira 209 As variáveis de decisão são x ij , onde i corresponde à fonte (localidade fornecedora) e j corresponde ao destino (localidade destino) e y i se a localidade será selecionada ou não. O modelo ficará: MinZ = y y y y x x x x x x x x x x x x x x x x x x x x 110000 90000 85000 100000 1,25 1,25 1,60 0,55 1,90 1,35 1,65 1,70 0,75 0,85 1,85 0,95 0,90 1,25 2,30 0,85 1,15 1,50 1,75 2,50 1 2 3 4 11 12 13 14 15 21 22 23 24 25 31 32 33 34 35 41 42 43 44 45 + + + + + + + + + + + + + + + + + + + + + + + (Uma pequena revisão sobre a modelagem da função objetivo: os valores referentes às variáveis y y y y ; ; ; 1 2 3 4 dizem respeito ao custo fixo de cada localidade e os valores de x x x x ; ; ;... 11 12 13 45 são os valores do custo de transporte da fonte i para o destino j . A empresa optará pela localidade que apresentar o menor custo total, ou seja, a soma dos custos de transporte das mercadorias mais a soma do custo fixo da instalação.) sujeito a: x x x x x x x x x x x x x x x x x x x x 2500 4500 4000 10000 4000 11 21 31 41 12 22 32 42 13 23 33 43 14 24 34 44 15 25 35 45 + + + = + + + = + + + = + + + = + + + = (restrição de demanda) 11 12 13 14 15 21 22 23 24 25 31 32 33 34 35 41 42 43 44 45 40000 30000 25000 30000 + + + + + + + + + + + + + + + + x x x x x x x x x x x x x x x x x x x x (restrição de capacidade) 0 ij x (restrição de não negatividade) { } 0,1 i y (binário)
Image of page 211
U4 - Programação inteira 210 Montando o modelo no Excel, temos a imagem na figura 4.37. As fórmulas das células estão na tabela 4.6 Figura 4.37 | Modelo montado no Excel Fonte: elaborado pelo autor. Tabela 4.6 | Fórmulas das células Fonte: elaborado pelo autor. Célula Fórmula C13 =SOMA(C22:G22) C14 =SOMA(C23:G23) C15 =SOMA(C24:G24) C16 =SOMA(C25:G25) H13 =SOMA(C22:C25) H14 =SOMA(D22:D25) H15 =SOMA(E22:E25) H16 =SOMA(F22:F25) H17 =SOMA(G22:G25) I13 =I5*H22 I14 =I6*H23 I15 =I7*H24 I16 =I8*H25 I22 =SOMARPRODUTO(C5:H8;C22:H25)
Image of page 212
U4 - Programação inteira 211 O preenchimento dos parâmetros do Solver pede um pouco de atenção, pois o campo “Alterando Células Variáveis” deve ser preenchido com as células correspondentes às variáveis referentes às localidades e pelas variáveis binárias, conforme a figura 4.38. A solução encontrada pelo Solver é ilustrada na figura 4.39. Dentre todas as localidades, o Solver selecionou Londrina como a melhor opção, onde deve ser construída a nova planta. A escolha foi feita com o cálculo do custo de R$ 118.500,00, o menor dentre todas as alternativas. Figura 4.38 | Parâmetros do Solver Fonte: elaborado pelo autor. Figura 4.39 | Solução encontrada pelo Solver Fonte: elaborado pelo autor.
Image of page 213
U4 - Programação inteira 212 O mesmo modelo poderia ser usado caso o estudo pedisse para selecionar mais de uma localidade, se a demanda a ser atendida for maior que a capacidade de uma só planta, e também calculará a quantidade a ser atendida por cada planta (destino) para cada fonte. Escolha de localidades considerando um cenário futuro de maior prazo Descrição da situação-problema Imaginemos que no estudo anterior para a escolha da localidade da nova planta a empresa tenha trabalhado com dados de um cenário futuro de médio prazo. O diretor também tem informações das demandas para um período maior. Nesse novo cenário, o atendimento da demanda não será conseguido com somente uma planta, e a empresa pediu para você simular com os dados referentes ao cenário de longo prazo, que é demonstrado na figura 4.40, para chegar às localidades das novas plantas. Avançando na prática
Image of page 214
Image of page 215

You've reached the end of your free preview.

Want to read all 220 pages?

  • Fall '19
  • São Paulo, Segunda Guerra Mundial, aprendizagem, CONHECIMENTO

What students are saying

  • Left Quote Icon

    As a current student on this bumpy collegiate pathway, I stumbled upon Course Hero, where I can find study resources for nearly all my courses, get online help from tutors 24/7, and even share my old projects, papers, and lecture notes with other students.

    Student Picture

    Kiran Temple University Fox School of Business ‘17, Course Hero Intern

  • Left Quote Icon

    I cannot even describe how much Course Hero helped me this summer. It’s truly become something I can always rely on and help me. In the end, I was not only able to survive summer classes, but I was able to thrive thanks to Course Hero.

    Student Picture

    Dana University of Pennsylvania ‘17, Course Hero Intern

  • Left Quote Icon

    The ability to access any university’s resources through Course Hero proved invaluable in my case. I was behind on Tulane coursework and actually used UCLA’s materials to help me move forward and get everything together on time.

    Student Picture

    Jill Tulane University ‘16, Course Hero Intern

Stuck? We have tutors online 24/7 who can help you get unstuck.
A+ icon
Ask Expert Tutors You can ask You can ask ( soon) You can ask (will expire )
Answers in as fast as 15 minutes
A+ icon
Ask Expert Tutors